ClaimXperience Involve the Policyholder Improve the Process

ClaimXperience

ClaimXperience System Requirements

Policyholder Collaboration

Requires a current version of an Internet browser that has Active Scripting and cookies enabled.

View our release schedule for future release dates.

Adjuster Video Collaboration

For the best online experience, we recommend you use a computer with the following minimal requirements:

  • Google Chrome
  • Firefox

Adjuster Video Collaboration is also compatible with:

  • Internet Explorer 10+ with the video collaboration Internet Explorer plugin (32-bit mode).

Video Collaboration for the Policyholder

Policyholders must use an iOS or Android device that meets the following requirements:

iOS

  • iOS 10 or later
  • App is optimized for iPhone 5S and newer
  • Compatible with:
    • iPhone 5S
    • iPad (3rd generation or later)
    • iPad mini

Android

  • Android 4.1 (Jelly Bean) or later
  • Rear-facing camera