XactPRM

XactPRM System Requirements

For the best XactPRM online experience, we recommend you use a computer with the following minimum system requirements:

  • Google Chrome: version 20 and above
  • Internet Explorer version 11 and above
  • Microsoft Edge: version 20.10240 and above
  • Mozilla Firefox: version 19 and above

 

XactPRM Mobile System Requirements

Android smartphone or tablet

  • A smartphone or tablet using Android 4.1 (Jelly Bean) or later
  • A cellular data plan that includes Internet access  

iOS smartphone or tablet

  • A smartphone or tablet using iOS version 9 or later
  • A cellular data plan that includes Internet access